Skip to content
February 8, 2015 / kiranpatils

Error while upgrading TDS Version

Challenge:

We were upgrading our from TDS (Team Development for Sitecore) version from 4.0.0.45 to 5.0.0.20 and while doing that we faced following error:

Error 1 The “Version” parameter is not supported by the “GetBuildRuntimeVersion” task. Verify the parameter exists on the task, and it is a gettable public instance property. C:\Program Files (x86)\MSBuild\HedgehogDevelopment\SitecoreProject\v9.0\HedgehogDevelopment.SitecoreProject.targets 125 16 AutoDeploy.TDS.Core

Solution:

Did a quick search and unfortunately was not able to find anything. Then thought to ask to experts — Hedgehog support team. And Angel Uzunov helped me to fix the issue!

Here’s what they said:

Okay, if it’s on a dev machine, it means that the new TDS version wasn’t installed correctly (the old .targets file is still present despite the fact that you installed the new version). Uninstall TDS, make sure that the C:\Program Files (x86)\MSBuild\HedgehogDevelopment\SitecoreProject folder is removed (if you have to, remove it manually), and re-install the new version. I hope this will fix the error. As I said before, messing with different TDS versions can have unsupported consequences.

So, if you are working on upgrade, please follow this steps:

  1. Uninstall old version
  2. Make sure that the C:\Program Files (x86)\MSBuild\HedgehogDevelopment\SitecoreProject folder is removed (if you have to, remove it manually)
  3. And then install newer version!

Happy Sitecoring! 🙂

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: